AccueilAccueil  PortailPortail  RechercherRechercher  Dernières imagesDernières images  S'enregistrerS'enregistrer  ConnexionConnexion  



Le Deal du moment : -16%
HISENSE 43B30G – TV LED UHD 4K – 43″
Voir le deal
279.99 €

Partagez
 

 [VXACE]TRPG avec event extender, un bug incongrut

Voir le sujet précédent Voir le sujet suivant Aller en bas 
AuteurMessage
Jodge65
Habitant Lv.6
Habitant Lv.6
Jodge65


Masculin Age : 26
Inscrit le : 05/04/2011
Messages : 110

[VXACE]TRPG avec event extender, un bug incongrut Empty
MessageSujet: [VXACE]TRPG avec event extender, un bug incongrut   [VXACE]TRPG avec event extender, un bug incongrut Icon_minitimeVen 6 Sep 2013 - 14:06

Bon, voila après avoir eu un léger problème finalement régler, je suis tomber sur un problème un peu plus dur...

La fonction "mousse_hover" est bien, en l'état, mais voila, les image afficher ayant cette condition ne peuvent pas s'effacer... Pas trop gros comme problème, une simple image d'un pixel avec 0 opacité suffit, mais voila, la fonction qui utilise cette ensemble est un événement commun, qui fonctionne sous l'intérupteur 0001... Il m'est alors impossible de désactiver cette intérupteur, et don stopper la fonctionnons, sinon j'ai droit au message d'erreur sur le mot "hover" utiliser uniquement dans cette fonction....

Je vous invite a télécharger la dernière version en date ici afin de vous faire une idée plus précise du bug...


Dernière édition par Jodge65 le Mer 18 Sep 2013 - 15:27, édité 2 fois
Revenir en haut Aller en bas
Jodge65
Habitant Lv.6
Habitant Lv.6
Jodge65


Masculin Age : 26
Inscrit le : 05/04/2011
Messages : 110

[VXACE]TRPG avec event extender, un bug incongrut Empty
MessageSujet: Re: [VXACE]TRPG avec event extender, un bug incongrut   [VXACE]TRPG avec event extender, un bug incongrut Icon_minitimeVen 6 Sep 2013 - 18:53

C'est bon j'ai eu une illumination !!! En ajoutant des superflus (en l'occurance l'affichage de la valeur des dégât sur l’ennemie) je me suis rendu compte que j'avais un appelle de script sous cette forme :

Code:
FOR = actor_atk(V[V[115]])
INT = actor_magic(V[V[115]])
CHA = actor_luck(V[V[115]])
AGI = actor_agility(V[V[115]])
DEF = V[V[128]+5]
MDEF = V[V[128]+7]
ATK =  ((FOR*3)+(INT/2)+(CHA/2)+(AGI/2)+ V[V[115]+145])*(V[137]/100)
DEF = (V[137]/100)-((DEF*3)+(MDEF))
V[132] = ATK - DEF
Et fixnum m'as fait tilter, il y a un emboitage, et la commande DEF est ré-utiliser une 2nd fois, pour changer de valeur. Il semblerai qu'à la différence de ma Casio 35+ (calculette), RM n'apprécie pas de changer une valeur déjà paramétrer auparavant^^'

J'ai donc corriger par :
Code:
FOR = actor_atk(V[V[115]])
INT = actor_magic(V[V[115]])
CHA = actor_luck(V[V[115]])
AGI = actor_agility(V[V[115]])
DEF = V[V[128]+5]
MDEF = V[V[128]+7]
V[132] = ((FOR*3)+(INT/2)+(CHA/2)+(AGI/2)+
V[V[115]+145])*(V[137]/100)-((DEF*3)+(MDEF))
Bon ben maintenant on le saura, ce message d'erreur signifie qu'il y a une valeur ré-utiliser dans le même appelle de script ^^
Revenir en haut Aller en bas
 

[VXACE]TRPG avec event extender, un bug incongrut

Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1

 Sujets similaires

-
» [VXAce] L'Event Extender 4 (Le grimimimator)
» [VXAce] Event Extender, Le Grimator !
» [VXAce] Event Extender, Pathfinder
» [XP, VX, VXAce] Event Extender, Le Grimator !
» [XP, VX, VXACE] Event Extender - Flip Pictures

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
RPG Maker VX :: Entraide :: Problèmes et Solutions-
Créer un forum | ©phpBB | Forum gratuit d'entraide | Signaler un abus | Forum gratuit